Citroen C1, Peugeot 107, 108 & Toyota Aygo Owners Club. (Discount code for CityBugStore: C1OC)

It is currently Sun Feb 28, 2021 2:16 am

All times are UTC [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sun Jan 10, 2021 9:48 pm 
Offline

Joined: Sun Jan 10, 2021 9:23 pm
Posts: 1
Drives: C1 2014
Hello all,

My wife's C1 had code P0141 (related to the lambda sensors). It was due the annual service so she booked it into Citroen and asked them to look at it. They did and came back with a hard ECU fault and downstream sensor fault. The grand total was to be 1850 roughly. She was dealing with them and what concerned me was that in the conversation they offered to buy the car from her. Asking them if they swapped anything out or did any confirmation tests to prove the fault, they said no, it was just hooked up to the computer. Wondering if there was more to this and being a bit concerned about the offer to buy I moved it back home, replaced the sensor and reset the ECU using an OBD reader.

It was all fine for a few days then the 3 lights came on again (this is consistent with the fault throughout having this problem). The same fault codes.

Typically the lights come on within the first 10 minutes (or they don't come on at all, even in a long run - I took it to collect my daughter before Christmas an hour each way - no issues). The lights are latched until reset. The fault has not changed since the sensor change.

Now, over 1700 of the cost was going to be the ECU, so I want to be sure that is what it is. My questions are:

1. Has anyone come across this fault before and am I missing something obvious?
2. Before I start taking bits off, can anyone tell me where the ECU is and how to get to it?
3. Does anyone know where I can get a repair done to the ECU (that works) or a second hand one?
4. Is there a hard reset on the ECU itself?
5. If I change it myself, do I need any special set up kit that would stop me doing it (e.g. Citroen software / laptop)?

It looks like the Citroen garage might have been right, but for a car that now does less than 2000 miles a year (we live in the centre of town so it is not really needed), I am loathed to spend that sort of money on it. My plan is to get it fixed and sell it (it needs to be fixed properly - I won't sell it unless it is a permanent fix). On the other hand I don't want to spend 1700 pounds.

Other than that, good little car but this fault is more than a little frustrating. 2K a year, 20k on the clock, owned since new with full Citroen Service History, it needs using more hence the plan to sell.

Any help / suggestions much appreciated.


Top
 Profile  
 
PostPosted: Sun Jan 10, 2021 10:26 pm 
Offline
Club Founder
User avatar

Joined: Tue Jan 27, 2009 3:56 pm
Posts: 3695
Location: Exeter, Devon
Drives: Was C1 1.0 2005
ECU faults are pretty much unknown.

However faulty lambda sensors on Mk2 models, especially early ones is well documented.

Changing the sensors, and resetting the code should be more than enough.

_________________
Was 05 C1 1.0 White

Image

The NEW improved CityBugStore! - For all your C1, 107, 108 and Aygo needs. Support the club! Club Members Discount, enter code C1OC at checkout


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group