Citroen C1, Peugeot 107, 108 & Toyota Aygo Owners Club. (Discount code for CityBugStore: C1OC)

It is currently Wed Jun 26, 2019 7:04 pm

All times are UTC [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Mon May 20, 2019 4:57 pm 
Offline

Joined: Mon May 20, 2019 4:47 pm
Posts: 1
Drives: 107
Hi all

Hope you can offer some advice

The instrument cluster has stopped working on my wife's 107, speedometer, rev counter, and the LCD display are all dead. Engine and battery indicator lights in the centre circle still illuminate on ignition, but everything else is dead.

I've checked all the fuses and nothing appears to be blown :(

Image


Top
 Profile  
 
PostPosted: Tue Jun 25, 2019 12:56 pm 
Offline

Joined: Thu Feb 27, 2014 11:54 pm
Posts: 9
Drives: Citro├źn C1
It might be unrelated, but I've had minor problems with the radio as the contacts between the control panel and the unit didn't perform well.
The problem was becoming increasingly frequent until I was unable to control the radio.
Some day ago I disassembled the unit - pretty straightforward task - and separated the control panel from the ratio/cd unit.
There was no apparent oxidation on the contacts, but nonetheless, I applied some WD40 to the contacts and it solved the problem.
You might have a similar problem inside the instrument cluster.
From your picture, the speedometer and rev counter seems to be working.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 12 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group