Citroen C1, Peugeot 107, 108 & Toyota Aygo Owners Club. (Discount code for CityBugStore: C1OC)

It is currently Thu Nov 15, 2018 10:30 pm

All times are UTC [ DST ]




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Sun May 06, 2018 10:48 pm 
Offline

Joined: Wed Nov 19, 2014 9:31 pm
Posts: 17
Location: North Wilts
Drives: Pug 107
I have just swapped the instrument cluster on my manual 2010 107 in preparation for an MOT next week as the indicator right turn 'tell tale' lamp LED had failed. The replacement cluster came from a breaker on Ebay and was removed from a 2013 car.
All warning lamps now working satisfactory now but with the addition of the 2 Tronic warning lamp also illuminating plus an audible warning when ignition is turned off. I can only switch off this warning lamp and audible warning by disconnecting then reconnecting battery.
I can only assume the replacement cluster was removed from a 2 Tronic vehicle to give this problem.
So I'm posting on the off chance that someone else on here may have encountered same problem and can suggest a fix rather than having to source yet another replacement cluster.
What a pain just for an original snag of a 'tell tale' indicator lamp failure. Gone are the days when you swapped a 25p bulb!!!!!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: Google [Bot], PirateTimelord and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group