Citroen C1, Peugeot 107, 108 & Toyota Aygo Owners Club. (Discount code for CityBugStore: C1OC). - New users not working currently, New users please use 'City Bug Club' Facebook instead

It is currently Tue Sep 18, 2018 6:27 pm

All times are UTC [ DST ]




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Thu Feb 22, 2018 7:40 pm 
Offline

Joined: Sat Feb 10, 2018 6:10 pm
Posts: 1
Drives: 2006 Aygo
Hi my 2006 Aygo Black has a flashing SRS light, I did some fault finding and initially found that the clockspring/squib/Spiral Cable was broken so I replaced it.

However I am still getting the fault, I did a code scan and it is showing 2 different codes B1800 (Short in D Squib Circuit) and B1801 (Open in D Squib Circuit) however these seem to be affected by the connecter and I suspect there may be a faulty connection.

I have tested the continuity of the Squib and I am a bit confused by how it is wired, it has 2 connectors, one contaings 2 wires which plugs into the hareness for the Airbag circuit and the other with 1 wire for the horn. All of these are fine but the 2 airbag connectors seem to be joined together in the harness plug. Is this correct?

Also any other thoughts on how I can investigate the SRS fault? the car MOT has expired ;-)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group